PDA

View Full Version : Program Files on D:


Or Tsemah
06-12-2007, 05:11 AM
Hello,
Is there a way for me to display a message informing the users to install in D:\Program Files on every software installation in vista ?

Or.

felix8406
06-12-2007, 07:27 AM
As far as I know, when you install a program using its default settings, it will install on the "C" drive, but I'm sure there's a register hack however. You can also install the program on the "D" drive by choosing custom install instead. I've always install programs using custom install, it allows me to prevent the program from installing options that I may not want or have a need for.

Or Tsemah
06-12-2007, 07:34 AM
My Question: Is there a way for me to Auto-Notify the user to install using the "Custom" Option in D: ?

crabby
06-12-2007, 08:38 AM
Well... no, as that would mean editing all install executables to display the message. However, I do believe as Felix mentioned you can alter the registry to change the default installation drive to D:

crabby

Snuffy
06-13-2007, 11:02 AM
Have not tested this in Vista but I'm sure it still works.

After you back up your registry, this is how you can change this default location.

1. Navigate to:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
2. Find ProgramFilesDir whose default should be C:\Program Files
3. Change this to whatever directory you wish. I changed it to D:\Program Files for example.

Remember you have to reboot for your changes to show.

felix8406
06-13-2007, 01:37 PM
I would be very careful when proceeding with any registry changes. Like Snuffy mentioned, make sure your regstry is backed up before proceeding, but even this doesn't guarantee that you'll be able to bring your PC back if something goes wrong.

By the way, why would you want the programs to be installed ion a separate partion than the one Vista is installed? Even if they're installed on a separate partion, if the OS crashes, the programs will be useless.

Or Tsemah
10-05-2007, 05:11 AM
I want to install Vista on a Very Small HDD, and try to minimize the System Growth Levels (Mostly the Users\Program Files Folder)

Or

felix8406
10-05-2007, 07:51 AM
You could try creating a new environment variables to %ProgramFiles%/D:ProgramFiles. Not sure it’ll work. Click Start > Right-click Computer > Properties > Advanced system settings > Environment Variables System variables > New > Name the variable > Enter the value.