ABXZone Computer  Forums



Reply
 
Thread Tools Display Modes
Old 03-15-2016, 09:56 PM   #1
plainman007
Registered User
 
Join Date: Mar 2008
Posts: 782
System suddenly doesnt display anything. Powers on though. Please help.

Hi,

My PC is suddenly acting up. It doesn't show anything. Not even the bios screen or logo appears. When i power on the power LED glows and the HDD LED glows for like 5 secs or so as if its booting and after that only the power led is on. The heat sink fan is running. No display however.

I tested the monitor on another system and its OK. I tried pulling out the graphics card and tried hooking the monitor to vga output from the motherboard directly. Still no display. I don't think the system is even booting because the HDD led glows for only 5 secs after powering on. I tried pulling out the memory sticks n trying them one by one. Disconnected all my HDDs and tried with only one. Removed the CMOS battery and put a new one back in after 20 mins to reset the BIOS. Still same results.

Can any of you help to troubleshoot the problem please ?

Thanks
(Offline)   Reply With Quote

Advertisement [Remove Advertisement]
Old 03-15-2016, 10:09 PM   #2
fvbounty
Registered User
 
fvbounty's Avatar
 
Join Date: Nov 2002
Location: Alameda Ca
Posts: 20,418
Re: System suddenly doesnt display anything. Powers on though. Please help.

What power supply do you have and how old is it?
__________________
Asus ROG RAMPAGE VI APEX, Intel I7 7820K Cooled by Noctua NH D15S, 32 Gigs Corsair Dominator Platinum CMD32GX4M4A2666C15, Asus GTX 980 TI Strix, Samsung 950 Pro 512 Gig NVMe SSD W10 PRO, Samsung 840 EVO 500 gig data, 1 TB WD Black data, Corsair 540 case with Corsair HXi750 PS, Dell UltraSharp U3415W 34" monitor, Ducky Shine 5 RGB Keyboard, Mionix Naos 7000 mouse, AudioEngine A5+ Speakers driven by Asus Xonar U7 MKII USB sound card, AKG 7XX Red Limited Edition Headphones ....and some other stuff!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(Offline)   Reply With Quote
Old 03-15-2016, 10:44 PM   #3
Sandog
Moderator
 
Sandog's Avatar
 
Join Date: May 2003
Location: Alabama
Posts: 18,114
Re: System suddenly doesnt display anything. Powers on though. Please help.

Things I would start doing is checking power supply connections, reseat the memory or take half the sticks out, reseat the CPU. If you can get into BIOS I would reset it. Also check the voltages in BIOS for your power supply and make sure your hard disk is seen.

Alot of modern mobo's will beep is something is not working right. For example, two beeps means its a memory problem, etc (read troubleshooting in the mobo manual). Some boards come with a BIOS post code LED to show where the problem lies.

Good luck.
__________________
Windows 10 Pro / Corsair 760T Arctic White / ASUS ROG RAMPAGE VI APEX / Intel i7-7820X / ASUS ROG-STRIX-GTX1080-O8G-11GBPS / Corsair Dominator Platinum ROG Edition 32GB DDR4 DRAM 3200MHz C16 / SeaSonic Prime 750W Titanium / ASUS ROG SWIFT PG348Q / Intel Optane SSD 900P 480GB / Samsung 850 Pro 1TB / Ducky YoTS / ASUS ROG GLADIUS II / ASUS Essence STX / Audioengine HDP6, N22, S8 / AKG K712 PRO


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(Offline)   Reply With Quote
Old 03-16-2016, 01:47 AM   #4
plainman007
Registered User
 
Join Date: Mar 2008
Posts: 782
Re: System suddenly doesnt display anything. Powers on though. Please help.

Quote:
Originally Posted by fvbounty View Post
What power supply do you have and how old is it?
Hi how are you doing !

The power supply must be at least 4 years old. But used only for about 200 days maybe with just a few hours on those days since that entire PC is only for video edits and gets used maybe once a week kind of since it was assembled.
(Offline)   Reply With Quote
Old 03-16-2016, 01:53 AM   #5
plainman007
Registered User
 
Join Date: Mar 2008
Posts: 782
Re: System suddenly doesnt display anything. Powers on though. Please help.

Quote:
Originally Posted by Sandog View Post
Things I would start doing is checking power supply connections, reseat the memory or take half the sticks out, reseat the CPU. If you can get into BIOS I would reset it. Also check the voltages in BIOS for your power supply and make sure your hard disk is seen.

Alot of modern mobo's will beep is something is not working right. For example, two beeps means its a memory problem, etc (read troubleshooting in the mobo manual). Some boards come with a BIOS post code LED to show where the problem lies.

Good luck.
Hi Sandog,

There was no BIOS beep error. There is zero signal to monitor being output. Not even a blink. So theres no way of seeing BIOS screens etc. But it powers up and the fans inside are running. The mobo internal led on the board is glowing. Hard disks are running (can feel them). The pc case external power led is also glowing. HDD led glows for about 4-5 secs when i power on, after which its off only. I yanked out the nvidia graphics card and tried booting with MB VGA output yet no results.
(Offline)   Reply With Quote
Old 03-16-2016, 08:57 AM   #6
PeterT
CUSL2 > Sabertooth Z87
 
PeterT's Avatar
 
Join Date: Apr 2001
Location: Sunny Florida, USA
Posts: 5,232
Re: System suddenly doesnt display anything. Powers on though. Please help.

Try a different video card if you have one.
__________________
Current systems in the house, in chronological order. Mine in bold:
Desktop:
Corsair 550D & AX750, Asus Sabertooth
Z87, i7-4770K, 4x4GB Corsair Vengeance DDR3 1600, Asus Strix GTX 970 4GB, Samsung 850 EVO 500GB SSD
Antec SOLO II, Corsair TX650M, Asus ROG Crossblade Ranger, AMD A10-7890K, 4x4GB Corsair Vengeance DDR3 1600, Asus R9 270X DirectCU II TOP 2GB,

Samsung 840 EVO 250GB SSD
Antec SOLO, Corsair TX650, Gigabyte GA-EP45-UD3P, Intel Q9550, 4x2GB Corsair XMS2 DDR2 800,
EVGA GTX560Ti SC 1GB, Asus U3S6, Corsair Force GT 120GB SSD
Mobile:
Acer Aspire V5-552G-x852, AMD A10-5757M, Radeon 8750M 2GB, 2x4GB DDR3,
Samsung 840 EVO 500GB SSD
Acer Aspire V3-551G-X419, AMD A10-4600M, Radeon 7670M 2GB, 2x4GB Corsair DDR3 1333, Corsair Force GT 120GB SSD

Asus Eee PC 1215B-PU17, AMD E-350, 2x4GB Corsair DDR3 1333, OCZ Vertex 2 120GB SSD

(Offline)   Reply With Quote
Old 03-16-2016, 11:55 AM   #7
plainman007
Registered User
 
Join Date: Mar 2008
Posts: 782
Re: System suddenly doesnt display anything. Powers on though. Please help.

Quote:
Originally Posted by PeterT View Post
Try a different video card if you have one.
I removed the graphics card and tried booting with the on motherboard dsub connector hooked to the monitor. Didn't Work.
(Offline)   Reply With Quote
Old 03-16-2016, 12:15 PM   #8
Sir Skully
ABX Knight
 
Join Date: Feb 2001
Location: USA-GA
Posts: 41,058
Re: System suddenly doesnt display anything. Powers on though. Please help.

Maybe a bad CPU, there is no beeps with dead CPU, mobo will
light up, and fans will spin up, older HD will light up.
Even some times with things lighting up a PSU can still be bad.
__________________
ROG RAMPAGE VI APEX
i9-7900X... EK water cooled
ASUS STRIX GTX 1080 ti
VENGEANCE® RGB 32GB
OPTANE SSD-9 480G
SAMSUNG PRO 960 1tb M.2
MountainMods UFO case
Corsair 1200i watt psu
SAMSUNG 34" curved monitor
AudioEngine speakers
Ducky keyboard
ROG SPATHA gaming mouse

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(Offline)   Reply With Quote
Old 03-16-2016, 12:26 PM   #9
Sir Skully
ABX Knight
 
Join Date: Feb 2001
Location: USA-GA
Posts: 41,058
Re: System suddenly doesnt display anything. Powers on though. Please help.

Heres another if the PC for all intents is working, i.e. front panel lights, HDD spins up, optical drives have power,
fans start whirring, but there's no beep, the motherboard can also be the culprit...
__________________
ROG RAMPAGE VI APEX
i9-7900X... EK water cooled
ASUS STRIX GTX 1080 ti
VENGEANCE® RGB 32GB
OPTANE SSD-9 480G
SAMSUNG PRO 960 1tb M.2
MountainMods UFO case
Corsair 1200i watt psu
SAMSUNG 34" curved monitor
AudioEngine speakers
Ducky keyboard
ROG SPATHA gaming mouse

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(Offline)   Reply With Quote
Old 03-16-2016, 12:30 PM   #10
fvbounty
Registered User
 
fvbounty's Avatar
 
Join Date: Nov 2002
Location: Alameda Ca
Posts: 20,418
Re: System suddenly doesnt display anything. Powers on though. Please help.

What would happen if the bios battery was dead?
__________________
Asus ROG RAMPAGE VI APEX, Intel I7 7820K Cooled by Noctua NH D15S, 32 Gigs Corsair Dominator Platinum CMD32GX4M4A2666C15, Asus GTX 980 TI Strix, Samsung 950 Pro 512 Gig NVMe SSD W10 PRO, Samsung 840 EVO 500 gig data, 1 TB WD Black data, Corsair 540 case with Corsair HXi750 PS, Dell UltraSharp U3415W 34" monitor, Ducky Shine 5 RGB Keyboard, Mionix Naos 7000 mouse, AudioEngine A5+ Speakers driven by Asus Xonar U7 MKII USB sound card, AKG 7XX Red Limited Edition Headphones ....and some other stuff!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(Offline)   Reply With Quote
Old 03-16-2016, 12:32 PM   #11
Sir Skully
ABX Knight
 
Join Date: Feb 2001
Location: USA-GA
Posts: 41,058
Re: System suddenly doesnt display anything. Powers on though. Please help.

If it was me I'd look hard @ mobo/cpu. The mobo being 4 yrs old,
a part on it could of failed just from age... Cpu being the least likely
of the two to go...
__________________
ROG RAMPAGE VI APEX
i9-7900X... EK water cooled
ASUS STRIX GTX 1080 ti
VENGEANCE® RGB 32GB
OPTANE SSD-9 480G
SAMSUNG PRO 960 1tb M.2
MountainMods UFO case
Corsair 1200i watt psu
SAMSUNG 34" curved monitor
AudioEngine speakers
Ducky keyboard
ROG SPATHA gaming mouse

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(Offline)   Reply With Quote
Old 03-16-2016, 12:40 PM   #12
Sir Skully
ABX Knight
 
Join Date: Feb 2001
Location: USA-GA
Posts: 41,058
Re: System suddenly doesnt display anything. Powers on though. Please help.

Quote:
Originally Posted by fvbounty View Post
What would happen if the bios battery was dead?
A dead bios battery will usually only cause the system to not save bios settings, and not keep time/date.
__________________
ROG RAMPAGE VI APEX
i9-7900X... EK water cooled
ASUS STRIX GTX 1080 ti
VENGEANCE® RGB 32GB
OPTANE SSD-9 480G
SAMSUNG PRO 960 1tb M.2
MountainMods UFO case
Corsair 1200i watt psu
SAMSUNG 34" curved monitor
AudioEngine speakers
Ducky keyboard
ROG SPATHA gaming mouse

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(Offline)   Reply With Quote
Old 03-16-2016, 12:51 PM   #13
fvbounty
Registered User
 
fvbounty's Avatar
 
Join Date: Nov 2002
Location: Alameda Ca
Posts: 20,418
Re: System suddenly doesnt display anything. Powers on though. Please help.

Quote:
Originally Posted by Sir Skully View Post
A dead bios battery will usually only cause the system to not save bios settings, and not keep time/date.
Thanks Skully.....it was just a thought...lol
__________________
Asus ROG RAMPAGE VI APEX, Intel I7 7820K Cooled by Noctua NH D15S, 32 Gigs Corsair Dominator Platinum CMD32GX4M4A2666C15, Asus GTX 980 TI Strix, Samsung 950 Pro 512 Gig NVMe SSD W10 PRO, Samsung 840 EVO 500 gig data, 1 TB WD Black data, Corsair 540 case with Corsair HXi750 PS, Dell UltraSharp U3415W 34" monitor, Ducky Shine 5 RGB Keyboard, Mionix Naos 7000 mouse, AudioEngine A5+ Speakers driven by Asus Xonar U7 MKII USB sound card, AKG 7XX Red Limited Edition Headphones ....and some other stuff!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(Offline)   Reply With Quote
Old 03-16-2016, 01:04 PM   #14
exc
Registered User
 
Join Date: Apr 2002
Posts: 234
Re: System suddenly doesnt display anything. Powers on though. Please help.

Along with what Skully suggested, I also think you have to get into the bios to change a setting for the system to recognize the switch from "video card" to "on board video"!
Since you can not see anything on the monitor, if you have another video card, I would try that also.
But you stated that you removed the battery for 20 minutes and did a "CLR CMOS" so I do not think it is video related.
Bad memory module - you should still be able to get into the bios.
Most of the new mother boards - cpu not even required to get into the bios.
Power supply - is indeed required to get into the bios unfortunately.
Optical drive, or hard drives. even if bad you should still be able to get into the bios.
But, if you want to test the hard drive or optical drives, pop them into that other system you tested the monitor on, set them as slaves and see if they are recognized.

Good luck and keep us posted.
__________________
Excaliber!

Last edited by exc; 03-16-2016 at 01:24 PM..
(Offline)   Reply With Quote
Old 03-16-2016, 02:28 PM   #15
Sir Skully
ABX Knight
 
Join Date: Feb 2001
Location: USA-GA
Posts: 41,058
Re: System suddenly doesnt display anything. Powers on though. Please help.

Try starting up without any hard drives, A working mobo only needs
a video card / memory/PSU/CPU... to go into the bios...
__________________
ROG RAMPAGE VI APEX
i9-7900X... EK water cooled
ASUS STRIX GTX 1080 ti
VENGEANCE® RGB 32GB
OPTANE SSD-9 480G
SAMSUNG PRO 960 1tb M.2
MountainMods UFO case
Corsair 1200i watt psu
SAMSUNG 34" curved monitor
AudioEngine speakers
Ducky keyboard
ROG SPATHA gaming mouse

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(Offline)   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com

© 2006 - 2016 ABXZone Forums | About ABX Zone Forums | Advertisers | Investors | Legal | A member of the Crowdgather Forum Community